*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
CN 404 error
« on: October 27, 2015, 06:59:56 PM »
Heya,

I am getting a 404 error whenever I try to navigate to CN.  I am using Firefox 41.02 on OSX.  Any ideas why my internet is broken?
Th*rk is the worst person on this website.

*

Offline Pete Svarrior

  • e
  • Planar Moderator
  • *****
  • Posts: 12628
  • (>^_^)> it's propaganda time (◕‿◕✿)
    • View Profile
    • The Flat Earth Society
Re: CN 404 error
« Reply #1 on: October 27, 2015, 07:13:23 PM »
Are you actually getting a 404 error (which would have to be generated by the server, since SMF doesn't even do error codes), or just a "not found" page within SMF?

Also, could you post the exact URL from your address bar when this happens?
Read the FAQ before asking your question - chances are we already addressed it.
Follow the Flat Earth Society on Twitter and Facebook!

<Parsifal> I like looking at Chinese Wikipedia with Noto installed
<Parsifal> I don't understand any of it but the symbols look nice

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #2 on: October 27, 2015, 07:30:34 PM »
Are you actually getting a 404 error (which would have to be generated by the server, since SMF doesn't even do error codes), or just a "not found" page within SMF?

Also, could you post the exact URL from your address bar when this happens?

"404 Not Found"

http://forum.tfes.org/Themes/default/css/print.css?rc2

This is the page I navigate to when I click on the CN link from the main forum menu.
Th*rk is the worst person on this website.

*

Offline la xasop

  • Administrator
  • *****
  • Posts: 6486
  • Professional computer somebody
    • View Profile
Re: CN 404 error
« Reply #3 on: October 27, 2015, 07:33:12 PM »
"404 Not Found"

http://forum.tfes.org/Themes/default/css/print.css?rc2

This is the page I navigate to when I click on the CN link from the main forum menu.

That's a CSS file. It should never be linked directly. The CN link on the main menu points to this URL for me:

http://forum.tfes.org/index.php?board=2.0

Would you mind pasting the contents of the page source on the main page (right-click on the background and select "View Page Source")? You can use [code][/code] to make it scrollable rather than bloating your post.
when you try to mock anyone while also running the flat earth society. Lol

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #4 on: October 27, 2015, 08:27:02 PM »
"404 Not Found"

http://forum.tfes.org/Themes/default/css/print.css?rc2

This is the page I navigate to when I click on the CN link from the main forum menu.

That's a CSS file. It should never be linked directly. The CN link on the main menu points to this URL for me:

http://forum.tfes.org/index.php?board=2.0

Would you mind pasting the contents of the page source on the main page (right-click on the background and select "View Page Source")? You can use [code][/code] to make it scrollable rather than bloating your post.

I can't because someone had the good idea to limit the post size to 20,000 characters.  :P
Th*rk is the worst person on this website.

*

Offline la xasop

  • Administrator
  • *****
  • Posts: 6486
  • Professional computer somebody
    • View Profile
Re: CN 404 error
« Reply #5 on: October 27, 2015, 08:44:16 PM »
I can't because someone had the good idea to limit the post size to 20,000 characters.  :P

Ah, then you can just Pastebin it.
when you try to mock anyone while also running the flat earth society. Lol

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #6 on: October 27, 2015, 08:58:12 PM »
I can't because someone had the good idea to limit the post size to 20,000 characters.  :P

Ah, then you can just Pastebin it.

Like this?

http://pastebin.com/Wx06Trxx
Th*rk is the worst person on this website.

*

Offline la xasop

  • Administrator
  • *****
  • Posts: 6486
  • Professional computer somebody
    • View Profile
Re: CN 404 error
« Reply #7 on: October 27, 2015, 09:04:38 PM »
Like this?

http://pastebin.com/Wx06Trxx

Exactly like that, thanks. I'll have a look when I'm not eating.
when you try to mock anyone while also running the flat earth society. Lol

*

Offline la xasop

  • Administrator
  • *****
  • Posts: 6486
  • Professional computer somebody
    • View Profile
Re: CN 404 error
« Reply #8 on: October 27, 2015, 09:07:50 PM »
"print.css" doesn't even appear anywhere in that paste. Are you absolutely sure the CN link is sending you there?
when you try to mock anyone while also running the flat earth society. Lol

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #9 on: October 27, 2015, 09:09:23 PM »
"print.css" doesn't even appear anywhere in that paste. Are you absolutely sure the CN link is sending you there?

Just verified it again.
Th*rk is the worst person on this website.

*

Offline Pete Svarrior

  • e
  • Planar Moderator
  • *****
  • Posts: 12628
  • (>^_^)> it's propaganda time (◕‿◕✿)
    • View Profile
    • The Flat Earth Society
Re: CN 404 error
« Reply #10 on: October 27, 2015, 09:28:43 PM »
That URL appears to be referenced in the CN theme, in line 9 of the processed HTML:

<link rel="stylesheet" type="text/css" href="http://forum.tfes.org/Themes/default/css/print.css?rc2" media="print" />

Putting aside the fact that the CN theme probably shouldn't be referencing a CSS file that doesn't even exist, it seems that for some strange reason your browser arbitrarily decides to load that instead of the actual page.
« Last Edit: October 27, 2015, 09:42:10 PM by SexWarrior »
Read the FAQ before asking your question - chances are we already addressed it.
Follow the Flat Earth Society on Twitter and Facebook!

<Parsifal> I like looking at Chinese Wikipedia with Noto installed
<Parsifal> I don't understand any of it but the symbols look nice

*

Offline Pete Svarrior

  • e
  • Planar Moderator
  • *****
  • Posts: 12628
  • (>^_^)> it's propaganda time (◕‿◕✿)
    • View Profile
    • The Flat Earth Society
Re: CN 404 error
« Reply #11 on: October 27, 2015, 09:50:04 PM »
Rama, just to rule out that this isn't being caused by a dodgy browser add-on or something like that, could you please try reproducing this in Firefox's safe mode?
Read the FAQ before asking your question - chances are we already addressed it.
Follow the Flat Earth Society on Twitter and Facebook!

<Parsifal> I like looking at Chinese Wikipedia with Noto installed
<Parsifal> I don't understand any of it but the symbols look nice

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #12 on: October 28, 2015, 04:35:43 AM »
Rama, just to rule out that this isn't being caused by a dodgy browser add-on or something like that, could you please try reproducing this in Firefox's safe mode?

When starting in safe mode, I can navigate to CN properly.
Th*rk is the worst person on this website.

*

Offline Pete Svarrior

  • e
  • Planar Moderator
  • *****
  • Posts: 12628
  • (>^_^)> it's propaganda time (◕‿◕✿)
    • View Profile
    • The Flat Earth Society
Re: CN 404 error
« Reply #13 on: October 28, 2015, 08:31:47 AM »
Okay. In that case, the problem is almost certainly with one of your addons/plugins/whatchamacallit. You might be able to identify which one simply by turning them all off and turning them on one by one until stuff breaks.

I'll remove the line of code that references the non-existent CSS file since it shouldn't be there anyway. However, I couldn't tell you whether or not that will actually help in your case.
Read the FAQ before asking your question - chances are we already addressed it.
Follow the Flat Earth Society on Twitter and Facebook!

<Parsifal> I like looking at Chinese Wikipedia with Noto installed
<Parsifal> I don't understand any of it but the symbols look nice

*

Offline Rama Set

  • *
  • Posts: 7417
  • Round and round...
    • View Profile
Re: CN 404 error
« Reply #14 on: October 28, 2015, 08:33:34 PM »
Okay. In that case, the problem is almost certainly with one of your addons/plugins/whatchamacallit. You might be able to identify which one simply by turning them all off and turning them on one by one until stuff breaks.

I'll remove the line of code that references the non-existent CSS file since it shouldn't be there anyway. However, I couldn't tell you whether or not that will actually help in your case.

That did it.  It was an add-on called "search me".  I have removed it and everything is working fine now.  Thanks for the help!
Th*rk is the worst person on this website.